ParaJVE Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000021 [ParaJVE] Framework feature N/A 2009-01-14 12:59 2009-06-26 10:54
Reporter parabellum View Status public  
Assigned To parabellum
Priority normal Resolution fixed  
Status resolved   Product Version Release 0.6.0
Summary 0000021: Implement a Save / Load feature (emulator state persistence)
Description Having a way to save the current state of the emulator, then load it back later will greatly benefit to ParaJVE : The player would then be able to suspend and resume long gaming sessions, as well as submit specific testcases if appropriate.
Additional Information
Tags No tags attached.
Cartridge -
Attached Files png file icon load.png [^] (30,688 bytes) 2009-06-26 10:53

- Relationships

-  Notes
(0000020)
parabellum (administrator)
2009-04-13 01:41

Implemented a basic load/save feature (that only stores the CPU/VIA/PSG/RAM states at the moment). It is enough to save/load games in most cases, but it can sometime fail to load back, since the analogic cores are not saved yet.

Also, it is more like a QuickSave/QuickLoad feature, since the user cannot choose the target/source save file yet.
(0000022)
parabellum (administrator)
2009-06-26 10:42
edited on: 2009-06-26 10:45

ParaJVE can now save and reload its full state (including the vectors work buffer) in small binary files (usually less than 4KB).

There are two kind of save/load features :

Quick Saves

When the user presses F5, the emulator will save its current state in a Quick-Save slot ; this slot will be loaded back when F9 is pressed. Each game has a specific Quick-Save slot (basically derived from its binary CRC), so quick-saving one game will not overwrite the Quick-Save slot of another game.
When Quick-Saving/Quick-Loading, the user user is not asked for a file name, as all Quick-Save files are located in the <data/saves/quick> folder.

Standard Saves

When the "Save..." item is clicked in the "File" menu, ParaJVE asks the user a file name where to store its state. This file can be loaded back later, when selecting the "Load..." menu item. Please note that you can only load a save file containing data for the game currently emulated (for instance, you can't load a MINESTORM save if you are running the BERZERK game).

The save/load file selector dialog embeds a preview frame that lets you see the content of the selected save file (cf. picture attachment). It also provides 3 different file filters :
  • "All Files" : list all the files in the current folder,
  • "ParaJVE save files" : list only the files containing valid ParaJVE save files
  • "ParaJVE compatible save files" : list only the files containing valid ParaJVE save files that match the game currently emulated.




Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker